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Overview of This Tutorial 
This tutorial describes advanced concepts and procedures for analyzing imaging spectrometer data or hyperspectral 
images. You will use 1995 Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) data from Cuprite, Nevada, USA, to 
investigate the unique properties of hyperspectral data and how spectral information can be used to identify mineralogy. 
You will evaluate EFFORT “polished” spectra and Atmosphere REMoval (ATREM)-calibrated data, and review the Spectral 
Angle Mapper (SAM) classification method. You will compare apparent reflectance spectra (and images) to continuum-
removed spectra (and images), and you will evaluate Spectral Feature Fitting (SFF) results. Finally, you will learn how to 
use Multi Range SFF to define specific wavelength ranges for analyzing mineral spectral signatures. 
 
Files Used in This Tutorial  
CD-ROM: Tutorial Data CD #2  
Path: envidata/c95avsub  
 
The following files are required for this tutorial. All image data files have been converted to integer format by multiplying 
the reflectance values by 1000 to conserve disk space. A value of 1000 represents an apparent reflectance value of 1.0. 
 

File Description 
cup95_at.int (.hdr) Cuprite ATREM-calibrated apparent reflectance data. 50 bands 

(integer) 
cup95eff.int (.hdr) Cuprite EFFORT-corrected, ATREM-calibrated apparent 

reflectance data. 50 bands (integer) 
jpl1.sli (.hdr) JPL spectral library in ENVI format 
usgs_min.sli (.hdr) USGS spectral library in ENVI format 
cup95_av.roi Saved region of interest (ROI) locations 
cupsamem.asc Optional file of ROI mean spectra 
cupsam1.img (.hdr) SAM classification image using ROI image spectra endmembers 
cuprul1.img (.hdr) SAM rule image using ROI image spectra endmembers 
cupsam2.img (.hdr) SAM classification image using spectral library endmembers 
cuprul2.img (.hdr) SAM rule images using spectral library endmembers 
cup95_cr.dat (.hdr) Continuum-removed data (floating-point) 
cup95sff.dat (.hdr) SFF results 
cup95sfr.dat (.hdr) SFF Band Math results 
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Remove Residual Calibration Errors 
Empirical Flat Field Optimized Reflectance Transformation (EFFORT) is a correction method used to remove residual “saw-
tooth” instrument (or calibration-introduced) noise and atmospheric effects from ATREM-calibrated AVIRIS data. It is a 
custom correction designed to improve the overall quality of spectra, and it provides the best reflectance spectra available 
from AVIRIS data. EFFORT is a relatively automated improvement over the Flat-Field calibration method (Boardman and 
Huntington, 1996).  
 
The EFFORT correction method selects AVIRIS spectra that match a low-order polynomial estimate in a least-squares 
sense as representative, featureless spectra. These spectra are averaged and a mild gain factor is determined to remove 
systematic, coherent noise present in every spectrum, including small residual atmospheric effects near the 2.0 µm range 
attributable to CO2.  
 
You normally run EFFORT by selecting Spectral → Effort Polishing from the ENVI main menu bar, but you will not run 
EFFORT during this exercise. Instead, you will use AVIRIS data already corrected with EFFORT. 

Load EFFORT-Corrected Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 
 
2. Navigate to envidata/c95avsub and select cup95eff.int. Click Open. This file contains EFFORT-corrected,  

ATREM-calibrated, AVIRIS apparent reflectance data.  
 
3. From the Display group menu bar, select Tools → Profiles → Z Profile (Spectrum). A Spectral Profile plot 

window appears. 
 

4. In the Available Bands List, click Display #1 and select New Display.  
 

5. From the ENVI main menu bar, select File → Open Image File. Select cup95_at.int and click Open. This 
file contains the original ATREM-calibrated, AVIRIS apparent reflectance data (with no EFFORT correction).  

 
6. In the Available Bands List, select Band 193 (2.20 µm), click Gray Scale, and click Load Band.  

 
7. From the Display #2 menu bar, select Tools → Profiles → Z Profile (Spectrum). A Spectral Profile plot 

window appears. 
 

8. Compare the two spectral profiles.  

Compare EFFORT and ATREM Spectra  
1. From the Display #1 menu bar, select Tools → Link → Link Displays. A Link Displays dialog appears. 
  
2. Click OK to accept the default values.  

 
3. From the Display #1 menu bar, select Tools → Link → Dynamic Overlay Off to enable normal mouse 

interaction. Both spectral profiles show the spectrum for the current pixel.  
 

4. Move the Zoom box in an Image window and compare the corresponding ATREM and EFFORT spectra. Note 
where the major differences occur.  

 
5. From the Display #1 menu bar, select Tools → Pixel Locator, and position the cursor at location (503,581).  

 
6. Right-click in the Spectral Profile #1 plot window and select Plot Key to display the plot legend.  

 
7. Drag and drop the EFFORT spectrum into the Spectral Profile #2 plot window, by clicking the spectrum name 

from the Spectral Profile #1 plot window and dragging it into Spectral Profile #2.  
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8. Right-click in the Spectral Profile #1 plot window and select Plot Key to display the plot legend. 
 

9. From the Spectral Profile #2 menu bar, select Edit → Data Parameters. A Data Parameters dialog appears. 
 

10. Change the color of the EFFORT spectrum by selecting #1 X:205 Y:581 in the list and clicking the Color box to 
the desired color.  

 
11. In the Name field, add the text (EFFORT) to the end of the name. Similarly, add the text ATREM-Only to the 

name of the ATREM spectrum.  
 

12. Set the Right Margin field to 15 so you can view the full legend. 
 

13. Click Apply, followed by Cancel. 
 

14. Stack the spectra by selecting Options → Stack Plots from the Spectral Profile #2 menu bar. The plot should 
look similar to the following:  

 

 
 

15. Compare the EFFORT-corrected spectrum to the ATREM-only spectrum. The two are very similar, but small 
coherent noise perturbations have been removed from the EFFORT spectrum. You should also see the correction 
of residual CO2 at 2.01 µm.  

 
16. Right-click the first character of the EFFORT spectrum name in the Spectral Profile #2 plot window to delete the 

imported spectrum.  
 

17. Use the Pixel Locator to move the cursor to location (542,533). The corresponding EFFORT spectrum appears in 
Spectral Profile #1. 

 
18. Drag and drop this spectrum into the Spectral Profile #2 plot window. Compare the two spectra. What are the 

major differences?  
 

19. When you are finished, close all plot windows and Display #2. Keep cup95eff.int open for the next exercise. 
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Spectral Angle Mapper Classification 
Next, you will use image and laboratory spectra to classify the AVIRIS data using the Spectral Angle Mapper (SAM) 
algorithm. You will collect endmembers for SAM but will not actually run the algorithm. You will examine previously 
calculated classification results to answer specific questions about the strengths and weaknesses of the SAM classification.  
 
SAM is an automated method for comparing image spectra to individual spectra or to a spectral library (Boardman, 
unpublished data; CSES, 1992; Kruse et al., 1993a). SAM assumes that the data have been reduced to apparent 
reflectance (true reflectance multiplied by some unknown gain factor, controlled by topography and shadows). The 
algorithm determines the similarity between two spectra by calculating the spectral angle between them, treating them as 
vectors in n-D space, where n is the number of bands. 
 
Consider a reference spectrum and an unknown spectrum from two-band data. The two different materials are 
represented in a 2D scatter plot by a point for each given illumination, or as a line (vector) for all possible illuminations.  
 

 
  
Because SAM uses only the direction of the spectra, not the length, SAM is insensitive to the unknown gain factor. All 
possible illuminations are treated equally. Poorly illuminated pixels fall closer to the origin of the scatter plot. The color of 
a material is defined by the direction of its unit vector. The angle between the vectors is the same, regardless of the 
length. The length of the vector relates only to how fully the pixel is illuminated. The SAM algorithm generalizes this 
geometric interpretation to n-D space. SAM determines the similarity of an unknown spectrum t  to a reference spectrum 
r, by applying the following equation (CSES, 1992):  

 
which also can be written as:  

 
where nb equals the number of bands in the image.  
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For each reference spectrum chosen in the analysis of a hyperspectral image, the spectral angle α (in radians) is 
determined for every image spectrum (pixel). This value is assigned to the corresponding pixel in the output SAM image, 
one output image for each reference spectrum. The derived spectral angle maps form a new data cube with the number 
of bands equal to the number of reference spectra used in the mapping. Gray-level thresholding is typically used to 
empirically determine areas that most closely match the reference spectrum while retaining spatial coherence.  
 
The SAM algorithm implemented in ENVI takes as input a number of training classes, or reference spectra from ASCII 
files, ROIs, or spectral libraries. It calculates the angular distance between each spectrum in the image and the reference 
spectra or endmembers in n-dimensions. The result is a classification image showing the best SAM match at each pixel 
and a rule image for each endmember showing the actual angular distance in radians between each spectrum in the 
image and the reference spectrum. Darker pixels in the rule images represent smaller spectral angles⎯spectra that are 
more similar to the reference spectrum. The rule images can be used for subsequent classifications using different 
thresholds to decide which pixels are included in the SAM classification image.  

Select Image Endmembers  
 
1. In the Available Bands List, under cup95eff.int, select Band 193 (2.20 µm), click Gray Scale, and click Load 

Band.  
 

2. From the ENVI main menu bar, select Classification → Supervised → Spectral Angle Mapper to start 
collecting endmembers. A file selection dialog appears. Select cup95eff.int as the input file and click OK. An 
Endmember Collection:SAM dialog appears. 

 
3. From the Endmember Collection:SAM dialog menu bar, select Import → from ASCII file. A file selection dialog 

appears. 
 

4. Select cup95_em.asc and click Open. An Input ASCII File dialog appears. 
 

5. Hold down the <Ctrl> key and deselect Mean:Dark/black, Mean:Bright/playa, Mean:Silica? (Dark), and 
Mean:Alunite (2.18) in the Select Y Axis Columns list.  

 
6. Click OK to load the remaining endmember spectra into the Endmember Collection:SAM dialog.  

 
7. Click Select All, followed by Plot. An Endmember Collection Spectra plot window appears. 

 
8. From the Endmember Spectra menu bar, select Options → Stack Plots to offset the spectra. 

 
9. Right-click in the plot window and select Plot Key to display the legend. The result is shown in the following 

figure:  
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10. Normally, you would click Apply in the Endmember Collection:SAM dialog to start the classification, but because 

classification can take some time, preprocessed results are provided for this exercise.  
 

• If you have time, click Apply in the Endmember Collection:SAM dialog, enter output file names in the 
Spectral Angle Mapper Parameters dialog, and click OK. 

  
• Or, in the Endmember Collection:SAM dialog, click Cancel and continue with the following exercise.  

Execute SAM  

Open a SAM Classification Image  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 
 
2. Select cupsam1.img. The classification image has one band with coded values for each class. Click Open. 

 
3. In the Available Bands List, click Gray Scale. Click Display #1 and select New Display. 

 
4. In the Available Bands List, select Sam under cupsam1.img and click Load Band. The classes are automatically 

color-coded as follows:  
 

Mineral Color 
Zeolites White 

Calcite Green 

Alunite Yellow 

Kaolinite Red 

Illite/Muscovite Dark green 

Silica Blue 

Buddingtonite Maroon 

 
The number of pixels displayed as a specific class is a function of the threshold used to generate the classification. Just 
because a given pixel is classified as a specific mineral does not mean it is actually that mineral. SAM is a similarity 
measure, not an identifier. 

Open EFFORT-Corrected Data  
5. In the Available Bands List, click Display #2 and select New Display. 
  
6. Click RGB Color, then select Band 183, Band 193, and Band 207 under cup95eff.int. Click Load RGB.  

 
7. From the Display #3 menu bar, select Tools → Profiles → Z Profile (Spectrum).  

 
8. Compare the SAM classification results with the distributions shown in the color composite. 

Open SAM Rule Image 
9. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 
 
10. Select cuprul1.img and click Open. This rule image has one band for each classified endmember, with the 

pixel values representing the spectral angle in radians. Lower spectral angles (darker pixels) represent better 
spectral matches to the endmember spectrum.  

 
11. In the Available Bands List, click Gray Scale. Click Display #3 → New Display.  
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12. In the Available Bands List, select Rule (Mean:Zeolites) under cuprul1.img and click Load Band. 

 
13. Evaluate the image with respect to the color composite and the SAM classification image, as well as the ROI 

means and individual spectra in the Spectral Profile plot window.  
 

14. From the Display #4 menu bar, select Tools → Color Mapping → ENVI Color Tables.  
 

15. Use the Stretch Bottom and Stretch Top sliders to adjust the SAM rule thresholds to highlight those pixels 
with the greatest similarity to the selected endmember.  

 
16. Pull the Stretch Bottom slider all the way to the right and the Stretch Top slider all the way to the left to 

highlight the most similar pixels in white.  
 

17. Move the Stretch Bottom slider gradually to the left to reduce the number of highlighted pixels and show only 
the best SAM matches in white. You can use a rule image color composite or image animation if desired to 
compare individual rule images.  

 
18. Repeat the process with each SAM rule image. When finished, select File → Cancel from the ENVI Color Tables 

dialog menu bar.  
 

19. From the ENVI main menu bar, select Window → Close All Display Windows.  

Select Spectral Library Endmembers  
In this exercise, you will select endmembers again, but you will not actually perform the SAM classification. Previously 
saved SAM results will be used for comparisons. If you have time, you can perform your own SAM classification using 
spectral library endmembers.  
 

1. From the ENVI main menu bar, select Spectral → Spectral Libraries → Spectral Library Viewer. A Spectral 
Library Input File dialog appears. 

 
2. Click Open → Spectral Library. A file selection dialog appears. 

 
3. Navigate to envidata/spec_lib/jpl_lib and select jpl1.sli. Click Open.  

 
4. In the Spectral Library Input File dialog, select jpl1.sli and click OK. A Spectral Library Viewer dialog appears. 

 
5. Select ALUNITE SO-4A. A Spectral Library Plots window appears.  

 
6. Right-click in the Spectral Library Plots window and select Plot Key to view the spectral library name.  

 
7. In the Spectral Library Viewer dialog, select the following spectra to plot them in the same Spectral Library Plots 

window.   
 

BUDDINGTONITE FELDS TS-11A  
   CALCITE C-3D  
   CHABAZITE TS-15A (a zeolite mineral)  
   ILLITE PS-11A  
   KAOLINITE WELL ORDERED PS-1A  
 

8. Start the SAM endmember selection process by selecting Classification → Supervised → Spectral Angle 
Mapper from the ENVI main menu bar. You can also access this function from the ENVI Spectral menu. A 
Classification Input File dialog appears. 

 
9. Click Open → New File, navigate to envidata/c95avsub and select cup95eff.int. Click Open. 
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10. In the Classification Input File dialog, select cup95eff.int and click OK. An Endmember Collection: SAM dialog 

appears. 
 

11. From the Endmember Collection: SAM dialog menu bar, select Import → from Spectral Library file. A 
Spectral Input Library File dialog appears. 

 
12. Select jpl1.sli and click OK. The Input Spectral Library dialog appears. 

 
13. Hold down the <Ctrl> key and select the following spectra, then click OK:  

 
   ALUNITE SO-4A  
   BUDDINGTONITE FELDS TS-11A  
   CALCITE C-3D  
   CHABAZITE TS-15A (a zeolite mineral)  
   ILLITE PS-11A  
   KAOLINITE WELL ORDERED PS-1A 
 

The spectra are listed in the table of the Endmember Collection: SAM dialog. 
 

14. From the Endmember Collection: SAM dialog menu bar, select Import → from Spectral Library file again. A 
Spectral Input Library File dialog appears. 

 
15. Click Open → Spectral Library. A file selection dialog appears. 

 
16. Navigate to envidata/spec_lib/usgs_min and select usgs_min.sli. Click Open.  

 
17. In the Spectral Library Input File dialog, select usgs_min.sli and click OK. A new Input Spectral Library dialog 

appears. 
 

18. Select opal2.spc Opal TM8896 (Hyalite) and click OK. The spectrum is added to the table in the Endmember 
Collection: SAM dialog.  

 
19. In the Endmember Collection: SAM dialog, click Select All, followed by Plot. An Endmember Collection Spectra 

plot window appears.  
 

20. From the Endmember Collection Spectra menu bar, select Options → Stack Plots to vertically offset the spectra 
for comparison.  

 
21. Compare these spectra to the image spectra plotted in the previous SAM exercise.  

 
22. Since you will not actually be performing the SAM classification in this exercise, click Cancel in the Endmember 

Collection:SAM dialog to continue the exercise. If you have time, you can generate your own SAM classification 
by clicking Apply.  

Review SAM Results 

Open a SAM Classification Image   
1. Open the pre-calculated SAM classification image generated from spectral library endmembers by selecting File 

→ Open Image File from the ENVI main menu bar. A file selection dialog appears. 
 
2. Navigate to envidata/c95avsub and select cupsam2.img. Click Open. This classification image has one band 

with coded values for each class. 
 

3. In the Available Bands List, select Gray Scale.  
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4. Select Sam under cupsam2.img and click Load Band. The classes are automatically color-coded as follows:  

 
Mineral Color 
Zeolites White 

Calcite Green 

Alunite Yellow 

Kaolinite Red 

Illite/Muscovite Dark green 

Silica Blue 

Buddingtonite Maroon 

 
The number of pixels displayed as a specific class is a function of the threshold used to generate the classification. Just 
because a given pixel is classified as a specific mineral does not mean it is actually that mineral. SAM is a similarity 
measure, not an identifier. 

Open EFFORT-Corrected Data 
5. In the Available Bands List, click Display #1 and select New Display. 
  
6. Click RGB Color, then select Band 183, Band 193, and Band 207 under cup95eff.int. Click Load RGB. 

 
7. Compare the classification results with the distributions shown by the color-composite image, the previous 

classification using image spectra (cupsam1.img), and the library spectra. Use image linking for direct 
comparison if desired.  

Open SAM Rule Image 
8. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 
 
9. Navigate to envidata/c95avsub and select cuprul2.img. Click Open. Rule images have one band for each 

endmember classified, with the pixel values representing the spectral angle in radians. Lower spectral angles 
(darker pixels) represent better spectral matches to the endmember spectrum. 

 
10. In the Available Bands List, select Gray Scale. Click Display #2 → New Display.  

 
11. In the Available Bands List, select Rule (ALUNITE SO-4A) under cuprul2.img and click Load Band. 

 
12. Evaluate the image using the ENVI Color Tables as you did earlier; and with respect to the color composite, the 

SAM classification image, the ROI means, and individual spectra extracted using the Z Profile tool. Also, use a rule 
image color composite or image animation if desired to compare individual rule images.  

 
13. Repeat the process with each SAM rule image. Based upon the results of the two SAM classifications, answer the 

following questions:  
 

• What ambiguities exist in the SAM classification based on your images and spectra above? 
  
• Why are the two classifications so different? What factors could affect how well SAM matches the 

endmember spectra?  
 

• How could you determine which thresholds represent a true map of the selected endmembers?  
 

• Can you see the topographic shading effects in the SAM data? Why or why not? 
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• Sketch a map of the Cuprite surface mineralogy for all classes on a separate piece of paper. Do some 

classes co-occur?  
 

• In light of some of the ambiguities in the SAM classification, how could you select better 
endmembers?  

Optional: Generate New SAM Classified Images Using Rule Classifier  
If you have some extra time, try generating new classified images based on different thresholds in the rule images.  
 

1. Display the individual bands of one of the two previously calculated rule images (cuprul1.img or 
cuprul2.img) and define the threshold for the classification, by selecting Tools → Cursor Location/Value 
from the Display group menu bar and browsing the image. You can also define thresholds by selecting Tools → 
Color Mapping → Density Slice from the Display group menu bar.  

 
2. From the ENVI main menu bar, select Classification → Post Classification → Rule Classifier. A Rule Image 

Classifier dialog appears. 
 

3. Select the same rule image you viewed in Step 1 and click OK. A Rule Image Classifier tool dialog appears. 
 

4. Click the Classify by toggle button to select Minimum Value, and enter the previously defined SAM threshold. All 
of the pixels with values lower than the minimum value will be classified. Lower thresholds result in fewer pixels 
being classified.  

 
5. Click Quick Apply or Save to File to begin the processing. The new classification image appears.  

 
6. Compare with previous classifications.  

Close Files and Plots  
To close all of the files used in this portion of the exercise, select File → Close All Files from the Available Bands List 
menu bar, then click Yes. To close all of the spectral plots, select Window → Close All Plot Windows from the ENVI 
main menu bar.  
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Spectral Feature Fitting and Analysis 
Spectral Feature Fitting (SFF) is an absorption-feature-based method for matching image spectra to reference 
endmembers, similar to methods developed at the U. S. Geological Survey (Clark et al., 1990, 1991, 1992; Clark and 
Swayze, 1995). 
  
Most methods for analyzing hyperspectral data still do not directly identify specific materials. They only indicate how 
similar a material is to another known material or how unique it is with respect to other materials. However techniques 
for direct identification of materials―via extraction of specific spectral features from field and laboratory reflectance 
spectra―have been in use for many years (Green and Craig, 1985; Kruse et al., 1985; Yamaguchi and Lyon, 1986; Clark 
et al., 1987). Recently, these techniques have been applied to imaging spectrometer data, primarily for geologic 
applications (Kruse et al., 1988; Kruse, 1988; Kruse, 1990; Clark et al., 1990, 1991, 1992; Clark and Crowley, 1992; Kruse 
et al. 1993b, 1993c; Kruse and Lefkoff, 1993, Swayze et al., 1995).  
 
All of these methods require you to reduce data to reflectance and to remove a continuum from the reflectance data prior 
to analysis. A continuum is a mathematical function used to isolate a particular absorption feature for analysis (Clark and 
Roush, 1984; Kruse et al, 1985; Green and Craig, 1985). A continuum corresponds to a background signal unrelated to 
specific absorption features of interest. Spectra are normalized to a common reference using a continuum formed by 
defining high points of the spectrum (local maxima) and fitting straight line segments between these points. The 
continuum is removed by dividing it into the original spectrum. 
 

 
  
SFF requires you to select reference endmembers from either the image or a spectral library, to remove the continuum 
from both the reference and unknown spectra, and to scale each reference endmember spectrum to match the unknown 
spectrum. SFF produces a scale image for each endmember selected for analysis by first subtracting the continuum-
removed spectra from one endmember (inverting it), and making the continuum zero. SFF determines a single 
multiplicative scaling factor that makes the reference spectrum match the unknown spectrum. Assuming that a 
reasonable spectral range has been selected, a large scaling factor is equivalent to a deep spectral feature, while a small 
scaling factor indicates a weak spectral feature.  
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SFF then calculates a least-squares-fit, band-by-band, between each reference endmember and the unknown spectrum. 
The total root-mean-square (RMS) error is used to form an RMS error image for each endmember. An optional ratio 
image of Scale/RMS provides a fit image that is a measure of how well the unknown spectrum matches the reference 
spectrum on a pixel-by-pixel basis.  

Open and Load the Continuum-Removed Data  
For this exercise, you can use pre-calculated data if you do not want to create your own continuum-removed data. If you 
want to use pre-calculated data, skip to Use Pre-Calculated Data below.  

Create Your Own Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. Select 

cup95eff.int and click Open. 
 
2. From the ENVI main menu bar, select Spectral → Mapping Methods → Continuum Removal. A Continuum 

Removal Input File dialog appears. 
 
3. Select cup95eff.int, perform spectral subsetting if desired to limit the spectral range for continuum removal, 

and click OK.  
 

4. Enter an output filename for the continuum-removed data, and click OK. This image will have the same number 
of spectral bands as the input image if you did not perform spectral subsetting.  

Use Pre-Calculated Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. Select 

cup95_cr.dat and click Open. This file contains continuum-removed, floating-point data (0 - 1.0) derived from 
the AVIRIS EFFORT-calibrated apparent reflectance data.  

 
2. In the Available Bands List, select Band 193 (2.20 µm), select the Gray Scale radio button, and click Load 

Band.  
 

3. From the Display group menu bar, select Tools → Profiles → Z Profile (Spectrum). A Spectral Profile plot 
window appears.  

 
4. From the Spectral Profile menu bar, select Edit → Plot Parameters. A Plot Parameters dialog appears. 

 
5. Select the Y-Axis radio button. Enter Range values of 0.5 to 1.0. Click Apply.  

 
6. Click Cancel to close the Plot Parameters dialog.  

 
7. Move the Spectral Profile window to the bottom of the screen for comparison with the EFFORT data.  

Open EFFORT-Corrected Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. Select 

cup95eff.int and click Open. This file contains EFFORT-corrected,  ATREM-calibrated, AVIRIS apparent 
reflectance data. An RGB composite is automatically loaded into a new display group. 

 
2. In the Available Bands List, under cup95eff.int, select Band 193 (2.20 µm), select the Gray Scale radio 

button, and click Load Band.  
 

3. From the Display #2 menu bar, select Tools → Profiles → Z Profile (Spectrum). A #2 Spectral Profile plot 
window appears. 

 
4. From the #2 Spectral Profile menu bar, select Edit → Plot Parameters. A Plot Parameters dialog appears. 
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5. Select the Y-Axis radio button. Enter Range values from 0 to 500. Click Apply. 

 
6. Click Cancel to close the Plot Parameters dialog.  

 
7. Move the #2 Spectral Profile window to the bottom of the screen for comparison with the continuum-removed 

data.  

Compare Continuum-Removed Spectra with EFFORT Spectra  
1. From the Display #1 menu bar, select Tools → Link → Link Displays. A Link Displays dialog appears. Click OK 

to accept the default values.  
 
2. From the Display #1 menu bar, select Tools → Link → Dynamic Overlay Off. 

 
• Alternatively, select Tools → Profiles → Additional Z-Profile and select the EFFORT data to link a 

second Z Profile to the spatial location in the continuum-removed image.  
 

Moving the Zoom box in the continuum-removed image causes the cursor location to be updated in the EFFORT-
corrected image. Both spectral profiles show the spectrum for the current pixel. You should see how the 
continuum-removed spectrum normalizes and enhances spectral features.  

 
3. From the Display #1 menu bar, select Tools → Pixel Locator. Enter the pixel location (503,581) and click 

Apply. Compare the continuum-removed spectrum to the EFFORT spectrum.  
 

 
 

4. Move the cursor location to (542,533) and compare the two images. Note how continuum-removal affects the 
spectrum.  

 
5. Try selecting some other points in the two images using the Pixel Locator and compare the spectra. What are the 

major differences? What improvements in visual analysis does the continuum-removal procedure allow?  

Compare Continuum-Removed and EFFORT-Corrected Images  
1. In the Available Bands List, click Display #2 and select New Display. 
 
2. Click the RGB Color radio button. Under cup95eff.int, select Band 183, Band 193, and Band 207. Click 

Load RGB.  
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3. Click inside the Image window that contains the EFFORT-corrected color composite (Display #3) to activate the 

dynamic overlay.  
 

4. Compare the continuum-removed image for Band 193 (Display #2) to the color composite (Display #3). Note the 
correspondence between dark areas in the continuum-removed image and red-to-purple areas in the color 
composite. The dark areas represent absorption bands near 2.2 µm.  

 
5. Move the Zoom box in the Display #2 Image window to some of these dark areas. Compare the corresponding 

spectral profiles for both the continuum-removed data and the EFFORT-corrected data, and note the image 
colors.  

 
6. In the Available Bands List, click Display #3 and select Display #1. Under cup95_cr.dat, select Band 207. 

Select the Gray Scale radio button and click Load Band. 
 

7. In the Image window for Display #1 (continuum-removed data), move the Zoom box to the dark areas and 
examine the spectra. You should see that these areas represent absorption features near 2.34 µm in the 
continuum-removed and EFFORT spectra.  

Close the EFFORT-Corrected Data File  
In the Available Bands List, select a band under cup95eff.int, then select File → Close Selected File from the 
Available Bands List menu bar. The associated display groups and spectral plots will close.  

Open and Load the SFF Scale and RMS Images  
For this exercise, you can use pre-calculated data if you do not want to create your own scale and RMS error images. If 
you want to use pre-calculated data, skip to Use Pre-Calculated Data below.  

Create Your Own Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. Select 

cup95_cr.dat and click Open.  
 
2. From the ENVI main menu bar, select Spectral → Mapping Methods → Spectral Feature Fitting. A file 

selection dialog appears. 
 
3. Select cup95_cr.dat file, perform optional spectral subsetting to limit the spectral range for fitting, and click 

OK. An Endmember Collection:Feature Fitting dialog appears. 
 

4. Use this dialog to import image or library spectra to use as endmembers in the SFF and click Apply. A Spectral 
Feature Fitting Parameters dialog appears.  

 
5. In the toggle button field, leave the default value of Output separate Scale and RMS Images. Enter an output 

filename, and click OK to create the scale and RMS error images for each endmember.  

Use Pre-Calculated Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. Select 

cup95sff.dat and click Open. This file contains the scale and RMS error images derived from SFF using 
image endmember spectra from the AVIRIS EFFORT-calibrated apparent reflectance data. Library spectra could 
also have been used, but the image spectra were used to allow direct comparison with other methods that use 
image spectra.  

 
2. In the Available Bands List, click Display #1 and select New Display. 

 
3. Under cup95sff.dat, select Scale (Mean: Kaolinite...). Select the Gray Scale radio button, and click Load 

Band.  
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4. In the Available Bands List, click Display #2 and select New Display. 

 
5. Under cup95sff.dat, select Scale (Mean: Alunite 2.16...). Select the Gray Scale radio button, and click 

Load Band.  
 

6. From one of the Display group menu bars, select Tools → Link → Link Displays. A Link Displays dialog 
appears. Click OK to link all three display groups. 

 
7. From one of the Display group menu bars, select Tools → Cursor Location/Value. Move the cursor around 

one of the images, and compare the data values for the two scale images. Although they appear similar as 
stretched images, their data values are different.  

 
8. Replace the kaolinite scale image with the corresponding RMS error image. In the Available Bands List, click 

Display #3 and select Display #2. Under cup95sff.dat, select RMS (Mean: Kaolinite...). Select the Gray 
Scale radio button, and click Load Band.  

 
9. Replace the alunite scale image with the corresponding RMS error image. In the Available Bands List, click 

Display #2 and select Display #3. Under cup95sff.dat, select RMS (Mean: Alunite...). Select the Gray 
Scale radio button, and click Load Band. 

 
10. Compare the RMS error images and use the Cursor Location/Value tool to compare their data values. Low RMS 

values correspond to good spectral matches.  

2D Scatter Plots of SFF Results  
1. From the Display #2 menu bar, select Tools → 2D Scatter Plots. A Scatter Plot Band Choice dialog appears. 
 
2. Under Choose Band X, select Scale (Mean: Kaolinite...).  

 
3. Under Choose Band Y, select RMS (Mean: Kaolinite...). 

 
4. Click OK. A Scatter Plot window appears. 

 
5. Draw a polygon ROI around low RMS values (for all ranges of Scale) in the Scatter Plot window, by clicking and 

dragging the left mouse button. Right-click to close the polygon and to define the ROI. The pixels corresponding 
to the ROI are highlighted in the Display #2 Image window (the kaolinite RMS error image).  

 
6. From the Scatter Plot menu bar, select Options → Change Bands. The Scatter Plot Band Choice dialog 

appears. 
 

7. Load other combinations of scale and RMS error data for the various endmembers.  
 

8. From the Scatter Plot menu bar, select File → Cancel.  

SFF Ratios and Fit Images  
For this exercise, you can use pre-calculated data if you do not want to create your own SFF fit images. A fit image 
represents a scale/RMS ratio for each endmember. If you want to use pre-calculated data, skip to Use Pre-Calculated 
Data below..  

Create Your Own Data  
1. From the ENVI main menu bar, select Spectral → Mapping Methods → Spectral Feature Fitting. A file 

selection dialog appears. 
 
2. Select cup95_cr.dat, perform optional spectral subsetting to limit the spectral range for fitting, and click OK. 

An Endmember Collection:Feature Fitting dialog appears. 
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3. Use this dialog to import image or library spectra to use as endmembers in the SFF and click Apply. A Spectral 
Feature Fitting Parameters dialog appears. 

 
4. Click the toggle button to select Output combined (Scale/RMS) images. Enter an output filename, and click OK to 

create fit images.  

Use Pre-Calculated Data  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. Select 

cup95sfr.dat and click Open. 
 
2. In the Available Bands List, click Display #3 and select Display #1. You will replace the continuum-removed 

data in Display #1 with a kaolinite fit image. 
 

3. In the Available Bands List, under cup95sfr.dat, select Fit (Mean: Kaolinite...). Select the Gray Scale radio 
button, and click Load Band. Bright pixels represent the best fit to the reference endmember spectrum of 
kaolinite.  

 
4. In the Available Bands List, click Display #1 and select Display #3. You will replace the alunite RMS image in 

Display #3 (from the previous exercise) with the kaolinite scale image. 
 

5. Under cup95sff.dat, select Scale (Mean: Kaolinite...). Select the Gray Scale radio button, and click Load 
Band. Following is a summary of what each display group should contain at this point: 

 
• Display #1: Fit (Mean: Kaolinite…) 
• Display #2: RMS (Mean: Kaolinite…) 
• Display #3: Scale (Mean: Kaolinite…) 

 
6. From one of the Display group menu bars, select Tools → Link → Link Displays. A Link Displays dialog 

appears. Click OK to link the fit, scale, and RMS images. Note how the scale and RMS images interact to produce 
the fit result. 

 
7. Create a color-composite image in a new display group, based on fit images for different endmembers. What can 

you conclude about the effectiveness of SFF for identifying specific endmembers?  
 

8. When you are finished with this exercise, select File → Close All Files from the Available Bands List menu bar. 
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Advanced SFF (Multi Range SFF)  
Mineral spectral signatures are usually characterized by a complex set of multiple absorption features. ENVI’s Multi Range 
SFF tool is designed to take advantage of these features by letting you define specific (and multiple) wavelength ranges 
for SFF comparison. 

Select One SFF Range for Dickite and Kaolinite  
1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 
 
2. Navigate to envidata/c95avsub and select cup95eff.int. Click Open. This file contains EFFORT-corrected,  

ATREM-calibrated, AVIRIS apparent reflectance data. A color composite image of bands 183, 193, and 207 is 
automatically loaded into a display group. 

 
3. From the ENVI main menu bar, select Spectral → Mapping Methods → Multi Range SFF → Use New 

Ranges. A file selection dialog appears. 
 

4. Select cup95eff.int and click OK. A Select Input Spectral Library dialog appears. 
 

5. Click Open → Spectral Library. Navigate to envidata\spec_lib\usgs_min and select usgs_min.sli. 
Click Open.  

 
6. In the Select Input Spectral Library dialog, select usgs_min.sli and click OK. An Input Spectral Library dialog 

appears.  
 

7. Choose the mineral spectra to use in the SFF analysis by selecting the mineral name in the dialog. Select 
dickite1.spc Dickite NMNH106242, hold down the <Ctrl> key, and select kaolin2.spc Kaolinite KGa-1 
(wxyl). Click OK. The Edit Multi-Range SFF Endmember Ranges dialog appears. 

Dickite 
8. In the Edit Multi-Range SFF Endmember Ranges dialog, the dickite spectrum is highlighted by default. In the plot 

window, drag the diamond-shaped marker to approximately 2.075 µm (indicated by xpos: 2.0750 above the 
plot). Right-click and select Set as Start Range to mark the starting point of the first continuum segment. Or, 
enter 2.075 in the Start Range field.  

 
9. In the plot window, drag the diamond-shaped marker to approximately 2.235 µm (indicated by xpos: 2.2350 

above the plot). Right-click and select Set as End Range to mark the ending point of the first continuum 
segment. Or, enter 2.235 in the End Range field.  

 
You can incrementally adjust the position of the markers, one library spectrum wavelength band position at a 
time, by clicking the up/down arrows in the Start Range and End Range fields.  

 
To zoom to a specific range, click and drag the middle mouse button in the plot window to draw a box around the 
desired spectral range. 

  
To zoom back out, click the middle mouse button once in the plot window.  

 
To reset the spectral range, right-click in the zoomed plot and select Previous Range or Reset Range.  

 
10. Click Add Range to add the selected spectral range to the Defined Ranges for the dickite1.spc Dickite 

NMNH106242 spectrum. By default, the fitted continuum is plotted along with the continuum-removed segment 
in the same plot. 

 
• Note: If the Add Range button is greyed out, click the up or down arrow once in the End Range field, 

then set it back to 2.235. The Add Range button should be activated now. 

19 
ENVI Tutorial: Selected Hyperspectral Mapping Methods 



 Tutorial: Selected Hyperspectral Mapping Methods 
11. Click and drag the middle mouse button inside the plot to draw a zoom box between 2.0 and 2.4 µm. 

 

 
• To remove the continuum plot, click the Cont check box to deselect it.  
• To remove the continuum-removed plot, click the CR check box to deselect it.  

Kaolinite 
12. In the Edit Multi-Range SSF Endmember Ranges dialog, switch the mineral to analyze. Select kaolin2.spc 

Kaolinite KGa-1 (wxyl). 
  

13. Repeat Steps 8-11 to highlight kaolinite features using the same spectral range (2.075 to 2.235 µm).  
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Run Multi Range SFF 
 

14. When finished selecting the wavelength range, click Save Ranges at the bottom of the dialog. An Output Multi 
Range SFF Ranges dialog appears. 

 
15. In the Enter Output Filename field, enter cup95_sff_range1.sff and click OK.  

 
16. In the Multi-Range SFF Endmember Ranges dialog, click OK to start the mapping process. A Multi-Range SFF 

Parameters dialog appears. 
 

17. In the toggle button field, keep the default value of Output separate Scale and RMS Images. Enter an output 
filename, and click OK to create the Scale and RMS error images.   

 
• Alternatively, click the toggle button to select Output Combined (Scale / RMS) Images, select the output 

filename, and click OK to create a fit image.  
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Analyze SFF Scale and RMS Images Using One Range  
The Available Bands List contains the Scale and RMS images derived from the Multi Range SFF using only one spectral 
range.  
 

1. In the Available Bands List, click Display #1 and select New Display. 
  
2. In the Available Bands List, select Scale (kaolini2.spc…), select the Gray Scale radio button, and click Load 

Band.  
 
3. From the Display #2 menu bar, select Tools → 2D Scatter Plots. A Scatter Plot Band Choice dialog appears. 

 
4. Under Choose Band X, select Scale (kaolini2.spc…) Under Choose Band Y, select RMS (kaolini2.spc…). 

Click OK. A Scatter Plot window appears. 
 

5. Rescale the scatter plot axes by selecting Options → Set X/Y Axis Ranges from the Scatter Plot menu bar. A 
Set Scatter Plot Axis Ranges dialog appears. 

 
6. In the Xrange fields, enter 0 to 1.1.  

 
7. In the Yrange fields, enter 0 to 0.1. Click OK. 

 
8. Draw a polygon ROI in the Scatter Plot between Scale values 0.2 and 1.0, and RMS values less than 0.04. Click 

and drag the left mouse button to define the ROI, and right-click to close the polygon. The pixels corresponding 
to the ROI are highlighted in the kaolinite scale image (Display #2). Use the following figure as a guideline: 

 

 
 

9. From the Scatter Plot menu bar, select Options → Export Class to export the highlighted pixels to the ROI 
Tool.  

 
10. From the Scatter Plot menu bar, select Options → Change Bands. A Scatter Plot Band Choice dialog appears. 
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11. Under Choose Band X, select Scale (dickite1.spc…) Under Choose Band Y, select RMS (dickite1.spc…). 

Click OK. A Scatter Plot window appears.  
 

12. Repeat Steps 5-9 for the dickite images. Before drawing an ROI, select Class → Items 1:20 → Green from the 
Scatter Plot menu bar to change the class color. Use the following figure as a guideline: 

 

 
 

13. Compare the SFF mapping results for the dickite and kaolinite mapping. Note the significant overlap between the 
two mineral image maps in the left side of the image.  

 
14. From the Display #2 menu bar, select Tools → Profiles → Additional Z Profile. A file selection dialog 

appears. 
 

15. Select cup95eff.int and click OK. A Spectral Profile window appears. 
 

16. Compare image spectra to spectral library plots of kaolinite and dickite. Note that the spectra show that there are 
only small occurrences of dickite towards the left side of the image.  

 
17. From the ENVI main menu bar, select Window → Close All Plot Windows.  

 
18. Close the two display groups.  

Select Two SFF Ranges for Dickite and Kaolinite  
Normally, a fitted continuum spanning a complex feature produces good mapping results, but occasionally you may need 
to further break down the complex feature to better separate the materials. In this exercise, you will select two ranges 
each with the kaolinite and dickite features.  
 
Normally, fitted continua are constrained to be convex-upward, but for this exercise, the fitted continua dip into the larger 
kaolinite/dickite absorption feature.  
 

1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears. 
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2. Navigate to envidata/c95avsub and select cup95eff.int. Click Open. This file contains EFFORT-corrected,  

ATREM-calibrated, AVIRIS apparent reflectance data. A color composite image of bands 183, 193, and 207 is 
automatically loaded into a display group. 

 
3. From the ENVI main menu bar, select Spectral → Mapping Methods → Multi-Range SFF → Use New 

Ranges. A file selection dialog appears. 
 

4. Select cup95eff.int and click OK. A Select Input Spectral Library dialog appears. 
 

5. Click Open → Spectral Library. Navigate to envidata\spec_lib\usgs_min and select usgs_min.sli. 
Click Open.  

 
6. In the Select Input Spectral Library dialog, select usgs_min.sli and click OK. An Input Spectral Library dialog 

appears. 
 

7. Choose the mineral spectra to use in the SFF analysis by selecting the mineral name in the dialog. Select 
dickite1.spc Dickite NMNH106242, hold down the <Ctrl> key, and select kaolin2.spc Kaolinite KGa-1 
(wxyl). Click OK. An Edit Multi-Range SFF Endmember Ranges dialog appears. 

Dickite  
1. In the Edit Multi-Range SFF Endmember Ranges dialog, the dickite spectrum is highlighted by default. In the plot 

window, drag the diamond-shaped marker to approximately 2.125 µm (indicated by xpos: 2.1250 above the 
plot). Right-click and select Set as Start Range to mark the starting point of the first continuum segment. Or, 
enter 2.125 in the Start Range field.  

 
2. In the plot window, drag the diamond-shaped marker to approximately 2.195 µm (indicated by xpos: 2.1950 

above the plot). Right-click and select Set as End Range to mark the ending point of the first continuum 
segment. Or, enter 2.195 in the End Range text box.  

 
3. Click Add Range to add the selected spectral range to the Defined Ranges for the dickite1.spc Dickite 

NMNH106242 spectrum. By default, the fitted continuum is plotted along with the continuum-removed segment 
in the same plot. 

 
• Note: If the Add Range button is greyed out, click the up or down arrow once in the End Range field, then 

set it back to 2.235. The Add Range button should be activated now. 
 
4. Click and drag the middle mouse button inside the plot to draw a zoom box between x-axis values 2.0 and 2.4 

µm.  
 

5. Repeat Steps 1-4 for a second feature for dickite, using a spectral range from 2.195 to 2.235 µm. 
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Kaolinite 
6. In the Edit Multi-Range SSF Endmember Ranges dialog, switch the mineral being analyzed. Select kaolin2.spc 

Kaolinite KGa-1 (wxyl).  
 

7. Repeat Steps 1-5 above (under "Dickite"), using the following ranges: 
 

• 2.135 to 2.175 µm 
• 2.185 to 2.225 µm 
 

 

Run Multi Range SFF 
8. Click Save Ranges. An Output Multi-Range SFF Ranges dialog appears. 

 
9. In the Enter Output Filename field, enter cup95_sff_range2.sff and click OK.  

 
10. In the Multi-Range SFF Endmember Ranges dialog, click OK to start the mapping process. The Multi-Range SFF 

Parameters dialog appears. 
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11. Click the toggle button to select Output separate Scale and RMS Images. Enter an output filename and click OK 
to create the scale and RMS error images.  

 
• Or, Click the toggle button to select Output combined (Scale / RMS) Images. Enter an output filename 

and click OK to create a fit image.  

Analyze SFF Scale and RMS Images Using Two Ranges  
The Available Bands List contains the scale and RMS images derived from the advanced Multi Range SFF.  

 
1. In the Available Bands List, under the output file you created in Step 11 above, select Scale (kaolini2.spc…), 

select the Gray Scale radio button, and click Load Band.  
 
2. From the Display group menu bar, select Tools → 2D Scatter Plots. A Scatter Plot Band Choice dialog appears. 

 
3. Under Choose Band X, select Scale (kaolini2.spc…) Under Choose Band Y, select RMS (kaolini2.spc…). 

Click OK. A Scatter Plot window appears. 
 

4. Rescale the scatter plot axes by selecting Options → Set X/Y Axis Ranges from the Scatter Plot menu bar. A 
Set Scatter Plot Axis Ranges dialog appears. 

 
5. In the Xrange fields, enter 0 to 1.1.  

 
6. In the Yrange fields, enter 0 to 0.1. Click OK. 

 
7. Draw a polygon ROI in the Scatter Plot between Scale values 0.2 and 1.0, and RMS values less than 0.04. Click 

and drag the left mouse button to define the ROI, and right-click to close the polygon. Use the following figure as 
a guideline. The pixels corresponding to the ROI are highlighted in the kaolinite scale image.  

 

 
 

8. From the Scatter Plot menu bar, select Options → Export Class to export the highlighted pixels to the ROI 
Tool.   
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9. From the Scatter Plot menu bar, select Options → Change Bands. A Scatter Plot Band Choice dialog appears. 

 
10. Under Choose Band X, select Scale (dickite1.spc…) Under Choose Band Y, select RMS (dickite1.spc…). 

Click OK. A Scatter Plot window appears.  
 

11. Repeat Steps 5-9 for the dickite images. Before drawing an ROI, select Class → Items 1:20 → Green from the 
Scatter Plot menu bar to change the class color. 

 

 
 

12. Compare the SFF mapping results for dickite and kaolinite. By defining multiple SFF ranges, you should see 
significantly less confusion between the minerals, and the kaolinite and dickite maps produce distinct spatial 
distributions.  

 
19. From the Display #2 menu bar, select Tools → Profiles → Additional Z Profile. A file selection dialog 

appears. 
 

20. Select cup95eff.int and click OK. A Spectral Profile window appears. 
 

21. Compare image spectra to spectral library plots of kaolinite and dickite. 
 

22. When you are finished, select File → Exit from the ENVI main menu bar. 
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